Limited throughput on data processing backend
Incident Report for Patchman
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 10, 2019 - 14:21 CEST
Monitoring
All systems in our processing cluster are currently performing as intended. We will continue to monitor the situation for any regressions.
Posted 3 months ago. Apr 08, 2019 - 17:29 CEST
Update
The Agent API is fully functional again, and performance is increasing on the data processing cluster. We are investigating whether this has indeed resolved the issues in full.
Posted 3 months ago. Apr 08, 2019 - 17:20 CEST
Update
We are currently performing emergency maintenance on the cluster, in order to resolve at least part of the performance problems. You may temporarily see Agent API connections cycle as a result of this.
Posted 3 months ago. Apr 08, 2019 - 17:09 CEST
Update
We are still in the process of identifying the root cause of this slowdown.

If, in the meantime, you have any questions about whether something you're seeing in the Portal is related to this incident, feel free to reach out to us at support@patchman.co.
Posted 3 months ago. Apr 08, 2019 - 12:49 CEST
Investigating
Our data processing cluster is currently experiencing performance issues, causing a lag in processing of incoming messages from agents. This is resulting in various pieces of information in the Portal being out-of-date, including scan times and detection data. We are currently working to identify the root cause of this problem, and will provide periodic updates here regarding our progress.
Posted 3 months ago. Apr 08, 2019 - 10:57 CEST
This incident affected: Agent API and Data Processing Infrastructure.